I came across the interesting blog “JavaFx and HTML5 differences” by Chika Okereke. Looking at the example code and comparing to the HTML Canvas version I thought the Java code could be made less verbose and easier to read.
Original Code
Path path_4 = new Path(); ObservableList shape_4 = path_4.getElements(); shape_4.add(new MoveTo(50,50)); shape_4.add(new LineTo(150,50)); shape_4.add(new LineTo(150,150)); shape_4.add(new LineTo(50,150)); shape_4.add(new LineTo(50,50)); path_4.setStrokeWidth(2); path_4.setStroke(Color.rgb(255,0,0));
So I hacked together a Extended version of the PathBuilder that ships with JavaFX 2.0 adding methods for all of the path elements like moveTo() etc. The end result seems much cleaner code to me, what do you think?
Code with new Builder
Path path4 = PathBuilderExtended.create() .moveTo(50, 50) .lineTo(150, 50) .lineTo(150, 150) .lineTo(50, 150) .closePath() .strokeWidth(2) .stroke(Color.RED) .build();
This seemed a lot cleaner and simpler to read. I have filed a feature request RT-19266 in JIRA to add this to the platform. Feel free to comment on the bug if you any feedback or better suggestions. Also I have attached a implementation of this builder to the bug so you can see how it would be implemented or use it with your code today.
Looks much better to me…it only shows what’s needed and hides all the boilerplate…nice 🙂
Yap sounds like a nice addition! 🙂
Good idea
I can see my file size dropping.
Thanks 🙂